Codeable info

WordPress Blank Page Problem For Certain Posts

Posted on by in Blog

Shortly after writing this article, I resolved the blank page problem I was having. I have kept the original article intact so that you can understand the problem I had fully and the steps I took. The solution is towards the end of the article :)

A WP Mods reader pointed out the other day that one of our articles was ‘missing’. It turns out that the article 50 Websites You Won’t Believe Are Using WordPress’ is not displaying any content(I believe this is the only article that is experiencing this problem, if not, please let me know!).

It’s something I have never come across before. The content shows in the post editor correctly and is still there in the database, however the post displays no content. Well, if I reduce the list from 50 websites to 34 the content is displayed but if any more text is input the article is blank. This would suggest that the problem is caused by too much text. In fact, the only article I could find on the subject, which is 2 years old, noted that the issue was due to the user of shortcodes or the limits of the Perl Compatible Regular Expression engine.

I didn’t think this was the case. After all, articles such as 500 Creative 404 Error Pages and The Ultimate Social Media Icon List have more text and more images displayed on them and both display with no problems. However, to rule out the possibility that the issue was being caused by my PHP.ini settings I contacted my hosting company Servint. They increased my limits though, as predicted, the issue still remained.

What I see in the post editor

What I see in the post editor

What is shown online
What is shown online

WP Mods author Zack Tollman was kind enough to look into this issue for me. We ruled out a number of plugins (and deactivated some that were reducing performance on the site) and looked at some other areas that could be causing the problem.

Here’s the strange thing. I copied the content into a new post and the article would still not display. This had me baffled because, as I noted previously, there are many articles that have more text and images (therefore the possibility the database row was corrupted or something was ruled out). The one glimmer of hope I have is that when I copied and pasted the article into my WordPress test area, the article published ok.

I have contacted my host again and asked if they can compare the two databases. Specifically, whether settings/limits are different on one database. The issue has been escalated to their Tier 2 department so hopefully they will be able to figure out what is wrong.

WordPress Blank Page Problem – What Resolved It

Less than 20 minutes after posting about this problem, Pippin Williamson asked if there was any short codes in the article as it could be short code from a plugin that was causing the glitch.

I looked over the article again. Nothing. All the article has is a few introductory paragraphs and then a list of 50 websites, followed by some closing text at the end. I did notice one thing that was included to separate the introductory paragraphs and the list itself – a horizontal rule i.e. the HTML <HR /> tag.

Once I removed the tag, the post displayed fine. I really can’t understand why. The article I read previously did mention short codes, however short codes are used to make styling and publishing content easier. The horizontal rule tag is a valid HTML/XHTML tag therefore I cannot understand why using it would make an article blank if a certain number of characters are exceeded. Plus, it still doesn’t explain why the article published fine with the horizontal rule tag on my test blog (plugin conflict as Pippin suggests perhaps?).

If anyone can shed any light into why a simple HTML tag can cause this problem, please leave a comment and I will update this article :)


Codeable info

Comments (5)

Comment by cord42 says:

This was the exact problem I was having and could not solve! The <hr> tag I was using in the post was causing it…no idea why but thanks so much for keeping this post up and giving me the resource that helped me to finally solve where my content in WordPress was disappearing to.

Comment by RickPuaPila says:

The content of my posts were not editable. When I pushed âہ“updateâ€Â wordpress returned a âہ“post editedâ€Â message, but the content did not change. I could change categories, tags, publish date, etc. but not the content of the post.

Later: All the posts disappeared. The home page displayed a 404 error and when I went into wp-admin, it showed that I had 0 posts.


Open up phpmyadmin and run âہ“repair table wp_postsâ€Â


Comment by Pippin says:

Kevin, are there any short codes in the post? IT could quite possibly be a short code from a plugin that is glitching.

Comment by Kevin Muldoon says:

You won’t believe it. An HR tag caused it. I’m really surprised by this. A simple horizontal rule caused the who article to go blank. Have you come across this before?

Comment by Kevin Muldoon says:

I’ve just figured it out haha. I’ll update the post with the solution :)

Codeable info